Can not load new configuration to NodeMCU ESP8266 v46 Sensatio Firmware

Critical Bug: yes
Reproducable: yes (Steps offered below)

Repro 5/5. Restart of app and device between each attempt.
Log into Monitor App with the bridge connected. Try to setup a new quick configuration. Experience that the app/device does nothing on button Click „Weiter“ and does not update the configuration on the device.

Configure custom configuration with online tool, try to scan QR code. Note that the app displays the error „Ungültiger Code Der Code ist kein gültiger Code zur Schnellkonfiguration dieser Applikation.“

Try to use custom configuration tool within the app - nothing happens when clicking „Abschließen“ button.

App Name: Monitor
App Operating System: iOS
App Running Device: iPhone XS Max
App OS Version: 14.4.2
App Version: 1.8.1 / Build 77

Problem Description:

Can not load a new configuration to the NodeMCU (pre installed sensatio).
Goal is to connect a BME280+4xADS1115 (each 3x PT1000 with 10kOhm Spannungsteiler)+Display.

Can you please share the link to the configuration you created?

Sure.

For example:

http://sns8.io/CeGuRF

Note that this one is only for one ADS1115 and one PT1000.
I tried with a dozen of other Setups with the same result.
I wasn’t even able to “re-do” the initial setup I did with only the BME280.

@Manuel any update?
I am sitting here on a lot of PT1000 and sensatio Hardware. Is there maybe a way to hard reset the MCU so I can do new setups (currently not sure if the issue is app related or Sensatio OS)?

Sorry for the late answer…

We have 2 issues here…

1.) I tried your setup and have no problem applying it to my hardware, so i guess its a problem related to your current configuration, seems like the system has problems deleting the old config for some reason.
I would need an access code + password (you can generate in the app) for the corresponding hardware (please send me as direct message), and then I can delete the current configuration manually. This will - as every config change - delete all your sensor data. If you need it, please make sure to export it first.

2.) We do have a problem with the current firmware with multiple ADS1115 it seems. This will unfortunately take a little until it can be resolved… but is scheduled for the next firmware update.

best regards
Manuel

Thanks a lot for the reply!

  1. okay, I‘ve send you the access info! Some sort of hard-reset feature would be nice for future roadmap and save you a lot of work for direct support.

  2. Oh, okay. What’s the generell release cycle?

Hello @11Schotter

Just a little heads up. The bug that causes #2 was identified and fixed, currently working on releasing v47… should be available soon :slight_smile:

#1 should be solved too (i sent you the details via private message)

Update:
…and is available now :slight_smile: