[Solved] BME280 setup no connection WAIT message

Hi,

I am currently setting up a new NodeMCU Amica v2 - ESP8266 with Sensatio Firmware.
The display ADS1115 is working and the module is registered and working in the Sensatio app.

The issue is, that I can’t get any values from the BME280 Sensor - only WAIT Info on the Display.

The VCC is on the 3v3 (+) and the GND on GND.
SCL is on D1 (together with the SCK display i+j 17) and SDA on D2 (together with the SDA display i+j 18)

I tried to setup the configuration with the Quicksetup and with the Online manual tool.

Any help would be appreciated!

Edit.

I was able to solve it. Looks like one cable had a disconnection. All values are shown!

1 Like

Hi. I’ve also had the same problem occasionally when installing the components on a Bredboard with loose wires. After soldering the wires directly to the components, this phenomenon was gone.
I suspect that if the initialization process of the I2C interface does not run propperly - e.g. due to loose contact - the sensor or the display will not work.
Maybe the SW designers will invent an interception routine that does more than just display “WAIT”.